images

Guide: Så får du iPhoto till iOS 5.0.1

När Apple släppte iPhoto så såg de till att detta program enbart finns till iOS 5.1 och inga äldre mjukvaruverisioner. Nu kan du dock installera detta om du sitter med iOS 5.0.1 via några enkla steg.

iPhoto finns att köpa i App store, men för att kunna använda det på din iEnhet måste man ha uppgraderat till iOS 5.1 annars kraschar det bara när man försöker öppna programmet. Med denna guide så får man Apple att tro att man har iOS 5.1.

En teori varför Apple valde att bara släppa iPhoto mot iOS 5.1 är att de hoppats på att folk skulle välja att lämna iOS 5.0.1 i form av denna ”lockvara”. Men som sagt, det är bara en spekulation och inget vi ska fördjupa oss i.

För att detta tweak ska fungera krävs det att man köpt iPhoto innan man följer denna guide.

Observera att din iEnhet måste vara jailbreakad!

Så här installerar du iPhoto steg för steg:

1. Börja med att hämta hem iFile i Cydia om du inte redan har det.

2. Ladda sen ner programmet iPhoto501fix, även det från Cydia.

3. När detta är klart, öppna iFile och navigera till följande:
/—>System—>Library—>CoreServices—>Systemversion.plist

4. Öppna nu Systemversion.plist som textfil.

5. Nu följer det viktigaste i installationen. Ändra i raden där det står:
5.0.1 till 5.1 Se bild nedan.

Värt att tillägga är att det står den mjukvara du har installerad i iEnheten. Har du t ex iOS 4.3.3 så står detta istället för som ovan angivet 5.0.1.

Nu är allt klart. Öppna nu iPhoto och se vad det har att erbjuda.
För dig som vill ha en videoguide i hur man gör kan kolla på den nedan.

iDevil

iDevil

Skribent

Dela:
  • Kha

    Jag kunde installera iPhoto från App Store när iOS 5.1 släppte ut :/.
    Jag behövde inte följa denna guiden, varför?

    Jag har iPhone 4 iOS 5.0.1 untethered

    • iDevil

      Kha kunde du öppna iPhoto på iOS 5.0.1?
      Problemet är att det kraschar på äldre mjukvaror, men detta tweak gör så att man inte får det problemet. Jag har ändrat lite i guiden så det framgår vad som gäller.

      Ber om ursäkt om det ställde till det för dig.

      • Kha

        Hej iDevil!
        Javisst! Appen funkar som den ska. Inga krasch har skett hittills.
        Appen funkar som den ska utan problem för mig.

        Blev bara förvånad varför man behövde gå igenom denna långa guiden för att få iPhoto på äldre iEnheter.
        När man kan installera appen via App Store gratis och sen är det klart att använda.

        Märkligt att appen kraschar/ej startar för folk med iOS 5.0.1 :/.
        Jag använder som sagt iPhone 4 16GB med iOS 5.0.1 untethered (hjälp av senaste redsnow), funkar fint.

  • Nettus

    Jag sitter oxå med en iphone 4 med IOS 5.0.1 men kan inte installera appen ens.. står bara att den kräver 5.1 har laddat ner det till min ipad.. men den är ju uppdaterad.. vilket va illa eftersom jag nu får vänta på jb till den.. luren uppdateras först när untether finns till 5.1.

  • iDevil

    Har man ändrat om textraden i iFile som nämns i guiden ovan så står det både i Cydia och under inställningar att man har iOS 5.1 installerat. Gissa om jag blev förvånad när jag såg detta… Undrar om det påverkar nåt om man väljer att göra en uppdatering till iOS 5.1 hos Apple…:)